Processing Ajax...

Title
Close Dialog

Message

Confirm
Close Dialog

Confirm
Close Dialog

Sublime text command line parameters

User Image
Joel Bodenmann
7 discussion posts
Hi,

I use Sublime Text 3 as my editor of choice. When I click on a file in the files list, the file opens successfully. However, I'd like the cursor to move to the corresponding line as well.
From the Sublime Text 3 documentation I found out that one can specify it through the command line parameters like this:

Code

sublime_text.exe myfile:53

Therefore, I adjusted the command line parameters in the FileSeek options like the following:

Code

"$file$:$line$"

However, nothing changed. The file still opens correctly but the cursor is always set to the very first row.

I opened my terminal to try it out manually. When I execute the line as written above, everything works as expected. The file opens and the cursor moves to the line specified.

Can anybody give me a hint? Why does it work manually but not out of the FileSeek settings?

Kind regards,
~ Joel Bodenmann
May 11, 2014  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Can you try it like this instead?

Code

"$file$":$line$


If that still doesn't work out, please let me know :)
May 12, 2014  • #2
User Image
Joel Bodenmann
7 discussion posts
Thank you very much for your reply.

I have tried that and the result is sadly the same: The cursor keeps staying in the first line.

Best regards,
~ Joel Bodenmann
• Attachment: Sublime Text.jpg [185,323 bytes]
Sublime Text.jpg
May 13, 2014 (modified May 13, 2014)  • #3
User Image
Joel Bodenmann
7 discussion posts
Thank you very much for the screenshot. I have the same settings but please note that I use SublimeText 3 as I mentioned in my initial post. You seem to be using SublimeText 2.
You can get SublimeText3 from here: http://sublimetext.com/3

Edit: I am also using FileSeek v3.2.0 (Beta 2)

Kind regards,
~ Joel Bodenmann
May 13, 2014 (modified May 13, 2014)  • #4
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Woops, sorry about that! The first Google result took me to Sublime Text 2 for some reason :(

At any rate, I've just tried it with Sublime Text 3, and it works fine there as well. Are you double-clicking the file to open it from FileSeek, or are you right-clicking and choosing "Open with Other Application?"
May 13, 2014  • #5
User Image
Joel Bodenmann
7 discussion posts
I always double clicked the file and that's when it was always opened at the first line of the file.
Now I just tried to do right click -> Open with other application and then it worked like expected!

Is there any way to let the file open at the correct line by just double clicking it as well?

Thank you very much for your help so far, it's being appreciated a lot.

~ Joel
May 13, 2014  • #6
Keith Lammers (BFS)'s profile on WallpaperFusion.com
No problem! Do you generally only open text-based files from your FileSeek searches? If so, you can change the default double-click operation to "Open with Other Application" on the Settings > Search tab :)
May 13, 2014  • #7
User Image
Joel Bodenmann
7 discussion posts
Thank you very much, everything is now working like I like it to.

Kind regards,
~ Joel
May 13, 2014  • #8
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Awesome, glad to hear it!
May 13, 2014  • #9
Was this helpful?  Login to Vote(-)  Login to Vote(-)