Title

Message

Confirm

<< DiscussionsReply

Searching OneDrive with Files On-Demand

Chris G1
72 discussion posts
I use Microsoft OneDrive with the Files On-Demand feature where files show up in Explorer but they are not downloaded until they are actually opened. I would like Fileseek to just search the filenames of these files and then I can decide whether to open them.
It appears because of the file handlers, Fileseek is causing OneDrive to download all files it touches.
Is there anyway to set a profile up where Fileseek will only search the filename and not content and prevent OneDrive downloading everything?
I have been able to successfully do this with the "Everything" (Voidtools) but I like the search interface better with Fileseek.
May 1, 2021  • #1
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Chris,

Interesting, if you head to the Advanced tab in FileSeek, can you uncheck "Process file contents using File Handlers" and see if that works for you?

If it does, you should be able to save a profile with that option unchecked.

Thanks!
May 3, 2021  • #2
Chris G1
72 discussion posts
Hi Owen,
Sorry for the delay!
So I did test on a folder with OneDrive files not downloaded to my machine (on-demand) with "Process file contents using File Handlers" UNCHECKED.
Unfortunately, I saw the OneDrive notification popup for every file that met the criteria.
Any chance you can confirm it happens on your end and add to address in a future release?
• Attachment: OneDrive Download Prompt.jpg [15,892 bytes]
OneDrive Download Prompt.jpg
OneDrive Download Prompt.jpg
May 7, 2021  • #3
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Chris,

Thanks for testing that for me. You can prevent searching the contents of the file by leaving the "Query" field empty, and just using the "Include Files" field. You should be able to set the mode for Include Files to "Text Query" and then enter the search query in there, while leaving the Query field blank.

Hope that helps!
May 12, 2021  • #4
Was this helpful?    
<< DiscussionsReply